[ VKontakte Optimizer ]

[ VKontakte Optimizer ] (//vkopt.net/forum/index.php)
-   VkOpt | Вопросы, Ошибки и Предложения (//vkopt.net/forum/forumdisplay.php?f=4)
-   -   Ошибки VkOpt'a (//vkopt.net/forum/showthread.php?t=6)

RX-3200 22.06.2019 03:10

https://vkopt.net/upd/scripts/vkopt_loader.js через Tampermonkey
теперь совсем не работает и в консоли десктопной Оперы пишет :
Код:

Refused to load the script 'https://vkopt.net/upd/scripts/vk_lib.js'  because it violates the following Content Security Policy directive: "script-src 'self' *.vk.com *.mail.ru s.ytimg.com platform.twitter.com cdn.syndication.twimg.com www.instagram.com connect.facebook.net telegram.org *.yandex.ru *.google-analytics.com *.youtube.com *.google.com google.com *.googleapis.com *.vkpartner.ru *.moatads.com *.gstatic.com *.google.ru securepubads.g.doubleclick.net cdn.ampproject.org www.googletagmanager.com googletagmanager.com *.vk-cdn.net 'unsafe-inline' 'unsafe-eval' blob:". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.
Refused to load the script 'https://vkopt.net/upd/scripts/vklang.js' because it violates the following Content Security Policy directive: "script-src 'self' *.vk.com *.mail.ru s.ytimg.com platform.twitter.com cdn.syndication.twimg.com www.instagram.com connect.facebook.net telegram.org *.yandex.ru *.google-analytics.com *.youtube.com *.google.com google.com *.googleapis.com *.vkpartner.ru *.moatads.com *.gstatic.com *.google.ru securepubads.g.doubleclick.net cdn.ampproject.org www.googletagmanager.com googletagmanager.com *.vk-cdn.net 'unsafe-inline' 'unsafe-eval' blob:". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback
Refused to load the script 'https://vkopt.net/upd/scripts/vkopt.js'  because it violates the following Content Security Policy directive: "script-src 'self' *.vk.com *.mail.ru s.ytimg.com platform.twitter.com cdn.syndication.twimg.com www.instagram.com connect.facebook.net telegram.org *.yandex.ru *.google-analytics.com *.youtube.com *.google.com google.com *.googleapis.com *.vkpartner.ru *.moatads.com *.gstatic.com *.google.ru securepubads.g.doubleclick.net cdn.ampproject.org www.googletagmanager.com googletagmanager.com *.vk-cdn.net 'unsafe-inline' 'unsafe-eval' blob:". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

да-да отдельное расширение для vk займёт отдельный процесс со всеми вытекающими, а дополнительный юзерскрипт в Tampermonkey такого не делает → выбор в пользу юзерскрипта очевиден

PS: исправьте в нём "http" на "https" (чтоб оно как инсекурный контент не резалось)
или совсем http://vkopt.net/upd/scripts/ на https://github.com/VkOpt/VkOpt/raw/master/source/ замените
PPS: и нет, это действие теперь ничего не меняет, хотя раньше помогало → т.е. и с https всё равно то же самое в консоль пишет и соответственно не работает, ибо скрипты не загружаются
PPPS: в профильной теме http://vkopt.net/forum/showpost.php?...3&postcount=76 уже несколько недель тишины

Евгений 73Rus 24.06.2019 21:41

Выдает ошибку 404 при попытке загрузки, что делать ?

nao777 25.06.2019 00:31

Ошибка 404. Подскажите, где для хрома инсталяху взять?

[LooM] 25.06.2019 03:36

Цитата:

Сообщение от Евгений 73Rus (Сообщение 73317)
Выдает ошибку 404 при попытке загрузки, что делать ?

Цитата:

Сообщение от nao777 (Сообщение 73318)
Ошибка 404. Подскажите, где для хрома инсталяху взять?

Пока с этим не разобрались, качайте последний crx с гитхаба.

Madentist 25.06.2019 10:11

Цитата:

Сообщение от [LooM] (Сообщение 73319)
Пока с этим не разобрались, качайте последний crx с гитхаба.

.crx при установке говорит: "Пакет недействителен: "CRX_HEADER_INVALID".

AlexK 25.06.2019 12:12

Браузер safari 11 версия, все работало до недавнего времени, но сейчас не могу поставить последнюю версию (190617). Safari пишет "Доверять?" но после нажатия расширение не добавляется, перед этим старое я удалил. Может кто сталкивался? Сам подозреваю что дело скорее всего не в скрипте, а в самом браузере, так как есть другой мак с абсолютно такой же системы и сафари, там все поставилось и работает.

[LooM] 25.06.2019 16:39

Цитата:

Сообщение от Madentist (Сообщение 73320)
.crx при установке говорит: "Пакет недействителен: "CRX_HEADER_INVALID".

Тут косяк либо со стороны авторов вкопта (мб расширение не подписано под CRX3 для хрома 73+), либо со стороны самого хрома (мб удаление из магазина как-то повлияло).
Попробуй распаковать crx архиватором и "Режим разработчика->Загрузить распакованное расширение", или отключить временно защиту в настройках, или подписать самому под CRX3 (сам не знаю как).
Или скачай другие хромиумы (можно и постарее версию, ниже 73-ей). Тот же Cent Browser спокойно ставит.

Наталья13 26.06.2019 11:19

Вложений: 1
У меня вот такая проблема, как ее решить?

LerOv 26.06.2019 17:16

При попытке посмотреть код любой вики-страницы (в окне, куда попадаешь по кнопке "Список вики-страниц") всегда появляется надпись "Nothing..." - на всех! Даже на тех, которые открываются в стороннем приложении "Исходный код вики-страниц" (но мне нужно в VKopt`е, пожалуйста)


Ещё раз - не выводится код вики-страниц, только надпись "Nothing".


Пожалуйста, исправьте! Я заранее премного благодарен :)

zalupakonya345 27.06.2019 20:36

Кароче, пока у вас ошибка скачивания для гугла (404), то просто скачайте с гитхаба свежую версию .crx файлика, откройте его как архив, распакуйте содержимое в любую папку, зайдите в chrome://extensions/ , включите режим разработчика, нажмите на кнопку "загрузить распакованное расширение" выбирайте ту папку с содержимым скрипта, и готово, мелочь только в том, что при каждом запуске браузера гугла, он будет говорить что у вас установлен стороннее расширение, но спокойно нажимаем крестик и пользуемся... ^_^ ^_^ ^_^


Часовой пояс GMT +4, время: 16:17.

Сервер бесплатных медицинских консультаций
Дачный форум. уДачное общение.

VkOpt 2007 - 2022
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Перевод от zCarot