[ VKontakte Optimizer ]

[ VKontakte Optimizer ] (//vkopt.net/forum/index.php)
-   VkOpt | Вопросы, Ошибки и Предложения (//vkopt.net/forum/forumdisplay.php?f=4)
-   -   Ошибки VkOpt'a (//vkopt.net/forum/showthread.php?t=6)

Вэлл 18.09.2021 23:31

Цитата:

Сообщение от grzl (Сообщение 74182)
Исправил, если кому-то надо:

1. Скачиваем отсюда: <ссылка удалена>
2. Распаковываем скачанный архив в отдельную папку.
3. Далее необходимо перейти в раздел управления расширениями находящийся по адресу chrome://extensions/
4. Активируем режим разработчика
5. Жмём "Загрузить распакованное расширение"
6. Выбираем папку, в которую распаковали расширение (VkOpt-master - builds - chrome )

P.S. Никаких вирусов нет, но можете проверить на VirusTotal.


Сорри, но не надо выкладывать код на всяких обменниках.
На гитхабе уже есть пулл реквест с исправлением. Можно временно собрать от туда, или дождаться релиза новой версии.

grzl 18.09.2021 23:41

Цитата:

Сообщение от Вэлл (Сообщение 74183)
Сорри, но не надо выкладывать код на всяких обменниках.
На гитхабе уже есть пулл реквест с исправлением. Можно временно собрать от туда, или дождаться релиза новой версии.


О, админы живы) Окей. Думал забили на проект и обновлений не будет.

Enigan 20.09.2021 15:52

Все уже в курсе, что ВК недавно обновился, и ввел некоторые фишки из Facebook.
Так вот, из-за этих обновлений VK Opt не мог открыть всплывающие окна для просмотра постов. (К примеру ты сейчас в сообщениях, нажал на уведомление и поверх сообщений показывает пост).
Также показывает внизу "Диалоги: {vals.dialogs_count}"

Бывают следующие ошибки:
Код:

Uncaught TypeError: Cannot set property 'innerHTML' of null
    at vkopt.js:6256
    at onDoneRequest (vk_lib.js:2001)
    at vk_lib.js:2039
    at XMLHttpRequest.AjPost.request.onreadystatechange (vk_lib.js:1280)

Код:

Uncaught (in promise) DOMException: Failed to execute 'insertBefore' on 'Node': The node before which the new node is to be inserted is not a child of this node.
    at onDone (https://st1-28.vk.com/dist/web/notifier.0144ae65c60759a9bab5.js?737a3e6e765d26194ffe757ef3f9e5c1:1:138805)
    at ctx.__ARG2__.onDone (chrome-extension://hoboppgpbgclpfnjfdidokiilachfcbb/scripts/vkopt.js:566:47)
    at https://st1-28.vk.com/dist/common.3929cc6f1d82e8240c18.js?65918260205127c97186:2:160805
    at C.processResponse (https://st1-28.vk.com/dist/common.3929cc6f1d82e8240c18.js?65918260205127c97186:2:148884)
    at https://st1-28.vk.com/dist/common.3929cc6f1d82e8240c18.js?65918260205127c97186:2:151945
    at newCallback (chrome-extension://hoboppgpbgclpfnjfdidokiilachfcbb/scripts/vkopt.js:537:25)
    at https://st1-28.vk.com/dist/common.3929cc6f1d82e8240c18.js?65918260205127c97186:2:361118

VKOpt v3.0.8.3 (Установлено через магазин Chrome)
Google Chrome v91.0.4472.124 (Официальная сборка), (32 бит)

Prince.sska 20.09.2021 23:21

скролл ленты не работает.. при попытке нажать на "к предыдущим записям" не происходит никаких действий.. хотя при отлюкчении вкОпт'а все работает должны образом.. и пофиксите "нажатие на любые ссылки" тобишь не работает переход по вкладкам на одной странице.. тобишь моя страница.. мои новости.. фотографии и т.д. и т.п. ничо не работает.. только если нажать на "открыть в новой вкладке" Жопэнь(:(

VitaliyShayko 21.09.2021 00:23

Цитата:

Сообщение от Prince.sska (Сообщение 74186)
скролл ленты не работает.. при попытке нажать на "к предыдущим записям" не происходит никаких действий.. хотя при отлюкчении вкОпт'а все работает должны образом.. и пофиксите "нажатие на любые ссылки" тобишь не работает переход по вкладкам на одной странице.. тобишь моя страница.. мои новости.. фотографии и т.д. и т.п. ничо не работает.. только если нажать на "открыть в новой вкладке" Жопэнь(:(

Переустанови дополнение или поставь скриптом.

darkmode113 21.09.2021 14:34

Загрузка для замены - удаленного фото не работает.
Хотя когда первый раз установил расширения - то всё работало!
Происходит ошибка JavaScript .и кнопки для загрузки изображения с пк . нету.
Заранее Спасибо!

Вот скрин вылетающей ошибки:
https://a.radikal.ru/a24/2109/e6/06d652436900.png

lynrayy 21.09.2021 16:59

Сегодня весь день вот эта ошибка слева сверху высвечивается по КД https://i.imgur.com/eQgngpl.png

sorokan 27.09.2021 10:35

Цитата:

Сообщение от VitaliyShayko (Сообщение 74187)
Переустанови дополнение или поставь скриптом.

Не работает, как описано выше. Ни расширение, ни скрипт. Firefox и Chrome.

sample0 27.09.2021 13:14

VkOpt: [code:8]
Invalid request: versions below 5.81 are deprecated. Version param should be passed as "v". "version" param is invalid and not supported. For more information go to https://vk.com/dev/constant_version_updates


кто, знает что с этим делать?

VitaliyShayko 27.09.2021 14:54

Цитата:

Сообщение от sorokan (Сообщение 74198)
Не работает, как описано выше. Ни расширение, ни скрипт. Firefox и Chrome.

Ну не знаю. У меня всё работает нормально. ¯\_(ツ)_/¯


Часовой пояс GMT +4, время: 06:34.

Сервер бесплатных медицинских консультаций
Дачный форум. уДачное общение.

VkOpt 2007 - 2021
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Перевод от zCarot